General Auto Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.
Sponsored by:
Sponsored by:

SX4 O2 sensor stuck rich

  #1  
Old 01-21-2019, 07:54 AM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default SX4 O2 sensor stuck rich

Hello, I have a 2012 Suzuki SX4 with a 1.6L 16v engine and AWD. We bought it second hand from a lady that crashed it back in 2015. Took a few months to fix but eventually it was finished. Except a check engine light. My scanner said it was a heater cicrcuit inside the second O2 sensor on bank 1. Ordered the part and changed it and the old one was really broken inside (It's a Bosch O2 sensor with 4 wires). But since then I have a new error code that says: P2271 O2 sensor signal stuck rich and the car has higher fuel consumption and hesitates in upper revs (around 4000 rpm). Yesterday I took a new scan and it had the upper mentioned code and a new pending fault which said: O2 sensor signal stuck lean. Don't know what to do please help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rilcoat
Boulevard C90T, Boulevard C50T
0
04-20-2017 09:45 PM
krmendez8
Boulevard M95, Boulevard M50
1
12-31-2010 11:44 PM
redcarwire
General Auto Tech
0
04-16-2010 10:08 PM
Xanthinic12
600, 750
0
11-20-2007 11:58 PM
chunyiplau
Suzuki Aerio SX & Aerio Sedan
1
10-10-2006 02:46 AM


Thread Tools
Search this Thread
Quick Reply: SX4 O2 sensor stuck rich


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.