04 GSXR 600 Electrical Problem....Please Help!

  #1  
Old 05-28-2007, 07:23 AM
Junior Member
Thread Starter
Join Date: May 2007
Posts: 2
Default 04 GSXR 600 Electrical Problem....Please Help!

So here's my problem...I was coming home the other night on my 04 GSXR 600, doing a moderate speed through town (35-45) and all of a sudden my gauges lights went out and my exterior lights stopped working (brake light, and all blinkers). The only thing that works on my gauge cluster is my high beam indicator. The head light works like normal (high beam and low) and the bike runs like nothing is wrong. I brought it home, tore it apart and went to town with a circut tester. First I checked all of the fuses (they were all good), then I looked for broken, damaged or loose connections but I found nothing. I have power going to my guages but none going to my blinkers/lights. Through all my "troubleshooting" I did find one thing. After plugging the main harness back into the gauge cluster (even with the key out of the bike) the tach will move from zero to redline then fall back to zero just like it does prior to starting. This leads me to believe that the gauges still work and it's a problem in the bike wiring somewhere. I have the Haynes repair manual and their advice is if any part of the guage cluster is not working to take it to any authorized suzuki shop. I noticed someone else on this forum had this problem back in march on his 04 GSXR 750 but unfortunately I haven't been able to contact him to see what the problem was. If anyone could shed some light on this for me it would be GREATLY appreciated. It is memorial day weekend and my bike is sitting on it's stands! Thanks in advance for any help!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Monster80
GS500F, GSX-R1000, GSX-R750, GSX-R600
0
06-10-2008 07:44 PM
gsxr 600 rider
GS500F, GSX-R1000, GSX-R750, GSX-R600
5
01-24-2008 11:09 AM
fuguy25
GS500F, GSX-R1000, GSX-R750, GSX-R600
0
06-18-2007 05:14 PM
DaveyXXX
GS500F, GSX-R1000, GSX-R750, GSX-R600
5
06-08-2006 12:02 PM
ghost brackets
General Motorcycle Tech
0
07-13-2005 04:27 PM


Thread Tools
Search this Thread
Quick Reply: 04 GSXR 600 Electrical Problem....Please Help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.