Help with speedo please

  #1  
Old 03-07-2006, 04:33 PM
Junior Member
Thread Starter
Join Date: Mar 2006
Posts: 1
Default Help with speedo please

Hi Guys,

I've been riding cruisers for the last 6 years, and just picked up my first sportbike, a 2000 GSXR750. Overall she is a nice bike, but my speedo is not working. Seller told me I would need a new speedo sensor, but I replaced it, and still the speedo doesn't work.

Can anyone tell me MPH per 1000 RPM in each gear? That way I can ride as I troubleshoot and fix the speedo.

Or, if you can help me out with the speedo, please do. The speedo reads 0 mph all the time. The tach, temp, and indicators all work. I tried replacing the speedo sensor.

Thanks
 
  #2  
Old 12-30-2006, 12:21 AM
Junior Member
Join Date: Dec 2006
Posts: 1
Default RE: Help with speedo please

Did you have any joy with this problem? My Dad has a similar problem and no one seems to have clue! Suzuki said buy a new this and that module thing and it might work and it might not.... guess which it was?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mgrefsrud
General Motorcycle Tech
0
08-10-2010 04:42 PM
disturbed_gsxr600
GS500F, GSX-R1000, GSX-R750, GSX-R600
0
07-23-2007 05:06 PM
seven
GS500F, GSX-R1000, GSX-R750, GSX-R600
0
09-09-2006 04:43 PM
Eraycer
Boulevard M95, Boulevard M50
0
05-11-2006 02:20 AM
ghost brackets
General Motorcycle Tech
0
07-13-2005 04:27 PM


Thread Tools
Search this Thread
Quick Reply: Help with speedo please


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.