Forenza not starting - Suzuki Forum - Suzuki Enthusiast Forums
 
 


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-21-2009, 08:55 AM
Junior Member
Thread Starter
 
Join Date: Jan 2009
Posts: 1
Default Forenza not starting

My daughter's 2004 Suzuki Forenza was misfiring and overheating, so the mechanic replaced the plugs, wires, then the pulleys, timing belt, water pump. This took care of the misfire and overheating, but now her car won't start sometimes. Acts like it wants to start, then spits and sputters and dies again. I was wondering if it could be the fuel filter, or fuel pump or just bad gas. We did add the dry gas additive to her tank yesterday.

Also, if it's possibly the filter, do you have to replace the pump too?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Suzuki Marauder FI light flashing and not starting n1ce5p1ce New Member Area 0 05-21-2012 12:17 PM
bike not starting up islander74 DR-Z400E, DR-Z250, DR-Z125L, DR-Z110, JR50 0 04-23-2009 09:44 PM
Re starting my '80 GS850L Eddielee General Motorcycle Tech 5 10-11-2005 09:33 PM
Problem with hot engine starting BenSta General Auto Tech 0 07-18-2005 02:13 PM
Katana 600 having trouble starting cold Empyrean General Motorcycle Tech 0 06-15-2005 04:40 PM


Tags
06, 2004, bad, firing, forenza, gas, misfire, misfires, miss, not, overheat, randomly, sputtering, start, starting, suzuki

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.