1995 Katana 750 stalls while riding!!! HELP

  #1  
Old 09-09-2007, 07:51 PM
Junior Member
Thread Starter
Join Date: Sep 2007
Posts: 1
Default 1995 Katana 750 stalls while riding!!! HELP

have a 1995 Suzuki Katana 750 that normally runs great, but lately when I go riding the bike will stall now. This seems to happen when I've been riding for atleast an hour +. What happens is i can be riding anywhere from 60 to 80 MPH when out of the blue everything just dies. The instrument panel, lights and motor die. The weird thing is that some times I can kick it into neutral and restart the bike while still moving. Everything only shuts off for seconds in most cases. At first I thought it was over heating but I've changed my mind since then. I've checked the battery (Good clean tight connections) and the voltage while revving the RPM's to 5000. The voltage reads 15.3v so that seems to be good. At idle it's around 13.5v. After checking that I checked the kickstand switch to see if that was killing the motor and yes it will kill the motor but when I tested this the instrument panel still was operational and the lights were on. Has anyone ever heard of an issue like this? Any help you could give me would be greatly appreciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kotty
Off Topic
1
02-16-2009 08:54 AM
95GIXXXER
PRIVATE For Sale / Trade Classifieds
1
03-13-2007 07:17 PM
Myne
General Motorcycle Tech
0
09-08-2006 01:15 AM
antdity3436
Suzuki Sportbikes
0
09-01-2006 12:30 AM
bedaught
PRIVATE For Sale / Trade Classifieds
1
08-10-2006 01:21 AM


Thread Tools
Search this Thread
Quick Reply: 1995 Katana 750 stalls while riding!!! HELP


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.