2005 vl1500

  #1  
Old 10-21-2011, 11:39 PM
Junior Member
Thread Starter
Join Date: Oct 2011
Posts: 1
Default 2005 vl1500

I just purchased a used VL1500 and I can't seem to find a manual online. I've already had a stator replaced since the bike crunked on me the way home from the dealership. They replaced the stator and the bike starts up fine. My concern is that, today, when starting it, it would quit idling quite easily (if I didnt give it gas). Also, when I look at the speedometer settings, I see a CHEC below the fuel level graph and it isn't until I start up the bike that I can cycle through the odometer, trip odometer, and clock (maybe one other display). Does the CHEC mean I need to check something? Or is it the default display when you have the keys in but the bike isn't started? And is there a way to reset that if if was pertaining to my previous issue? I should mention that there are Cobra after market pipes and what appears to be a Power Commander hook-up. Could my idle issues be due to the previous owner messing with the mapping? I'm not motorcycle-mechanic saavy but a quick learner.
 
  #2  
Old 08-21-2013, 04:49 PM
Junior Member
Join Date: Aug 2013
Posts: 1
Default

Hi firiend. Iīm a C90 owner in Brazil, and the "check" message is normal.
By the way, do you know some genuine statorīs seller in USA?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tallguy240
Boulevard C90, Boulevard C50
0
09-02-2009 09:03 PM
sonicrocket76
General Motorcycle Tech
0
02-02-2006 02:04 PM


Thread Tools
Search this Thread
Quick Reply: 2005 vl1500


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.