C90 breakdown

  #1  
Old 06-07-2006, 11:54 AM
Junior Member
Thread Starter
Join Date: Jun 2006
Posts: 1
Default C90 breakdown

I HAVE A 2005 C90. BOUGHT IT LAST YEAR. ADDED VANCE AND HINES LONG SHOTS WITH"QUIET BAFFLES"; COBRA FI2000; AND K&N AIR FILTER. SET FI2000 ON DEFAULT. BIKE RAN LIKE A CHARM. SMOOTH AND POWERFUL.
THIS YEAR THE BIKE IS BREAKING DOWN BADLY UNDER A LOAD. MISFIRES AND BACKFIRES ON ACCELERATION. DOES NOT OCCUR WITH ANY PREDICTABILITY. TRIED FRESH GAS; DRY GAS; CLEAN PLUGS; REPLACE PLUGS; CHECK TANK FOR DEBRIS (NONE); CHECK ALL ELECTRICAL CONNECTIONS; CHECK BATTERY - NO LUCK. MOST OF THE TIME IT RUNS FLAWLESSLY. THEN OUT OF NO WHERE IT FALLS ON ITS FACE. TACH NEEDLE WILL BOUNCE NOW AND THEN. NEVER POPS THRU EXHAUST ON DECELERATION WHEN RUNNING WELL. FIRST INDICATION OF BREAKDOWN IS WHEN IT POPS THRU EXHAUST ON DECEL.
NO SATISFACTION WHATSOEVER FROM THE DEALER. RUN OUT OF IDEAS. WHAT HAVE I MISSED? ANY IDEAS? WHO MAY KNOW? ONLY 2000 MILES ON THIS BIKE.
THANKS PAPAUMAU
 
  #2  
Old 06-13-2006, 10:59 PM
Junior Member
Join Date: Mar 2006
Posts: 4
Default RE: C90 breakdown

The symptom you describe sounds like the bike is running lean. Check to ensure you do not have a loose connection on your FI2000. Also, go to http://forums.delphiforums.com/RLCMC/start and post your question..lot of help for you there. -J
 
  #3  
Old 06-15-2006, 05:23 PM
Junior Member
Join Date: Jun 2006
Posts: 3
Default RE: C90 breakdown

I cant be much help with your problem, but you stated you had aftermarket pipes on your 05 C-90?!? I have been trying to find some for a while with no luck. Please, email me about what kind and your supplier if possible. [email protected]
 
  #4  
Old 07-16-2006, 07:53 PM
Junior Member
Join Date: Jul 2006
Posts: 2
Default RE: C90 breakdown

I have a C90 FI 2005, but does not have a tach. If the tach is aftermarket, try disconecting it and ride for some time without it to see if it stops the problem...I have read somewhere that tachs and C90 don't get along some times..
 
  #5  
Old 08-13-2006, 10:05 AM
Junior Member
Join Date: Aug 2006
Posts: 1
Default RE: C90 breakdown

Sounds like the ECM is going bad. That will give you the intermittant performance problems but won't show itself to diagnostic equipment until it starts breaking down again. Your ECM module is very heat sensitive. make sure your that the heat shield that is supposed to cover it is still there. Other than that, you might want to just replace it if the dealer can't find any other problems.
 
  #6  
Old 12-08-2007, 12:37 AM
Junior Member
Join Date: May 2007
Posts: 22
Default RE: C90 breakdown

Of course the dealer isnt gunna help u-they dont need to do any warranty work on an engine that is modified unless it is inside the engine itself. it would be like sayin yea i got this bike and ive completely changed the way it runs from intake to idle to exhaust and now there is a problem can u the dealer fix the problem that my mods(that arent stock or dealer backed) could have possibly created? id say the ecm is goin bad or the engine is running too lean. if u have messed with the FI system there could be an incompatibility going on too. Plus typing in caps is kinda rude[:@] and obnoxious.
 
  #7  
Old 01-07-2008, 01:38 PM
Junior Member
Join Date: Jan 2008
Posts: 1
Default RE: C90 breakdown

I have to agree, I would check all the connections on the FI2000 especially since the problem sounds to be intermittant. Sounds like a loose connector or maybe an issue with the FI2000 itself.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.