( HELP ) Suzuki C90 Running Rough On Cold Start Up

  #1  
Old 06-28-2009, 01:08 PM
Junior Member
Thread Starter
Join Date: Jun 2009
Posts: 3
Default ( HELP ) Suzuki C90 Running Rough On Cold Start Up

I have a 2008 Suzuki C90 1500KM only on it
Has anyone had any problems with the Suzuki C90 with it running realy rough on cold start up that it almost wants to turn off. After it warms up it's fine any buddy have any solustion or had some repaires done to that matter

When the bike starts up it starts great goes into high idle runs great when the fast idle drops off in around 15sec it goes into regular running idle it sounds like it wants to shut off after 2min it seams to be ok?

I took it in to two dealers it seens that they can't find the problem or don't want to waist there time because warranty does not pay much.

If any buddy have a idea's on this type of matter
 
  #2  
Old 07-08-2009, 12:14 PM
Junior Member
Join Date: Jan 2009
Posts: 5
Default

I have an 07 C-90 and it does the same thing. It starts up just fine and idlles for a few sec's then gets rough and dies.My dealer here in Reno also says it is fine but cant explain it.
 
  #3  
Old 07-13-2009, 04:36 PM
Junior Member
Join Date: Jul 2009
Posts: 1
Default

Just wandering did you put aftermarket pipes or gut you pipes ? I have a 2007 C50 and I had to put a fuel management system on mine there are a number of good ones out there I used the Cobra 2000 mod. I sujest if you add one your self . take it to someone you trust to fine tune it. mine is running great now.
Originally Posted by 820leo View Post
I have a 2008 Suzuki C90 1500KM only on it
Has anyone had any problems with the Suzuki C90 with it running realy rough on cold start up that it almost wants to turn off. After it warms up it's fine any buddy have any solustion or had some repaires done to that matter

When the bike starts up it starts great goes into high idle runs great when the fast idle drops off in around 15sec it goes into regular running idle it sounds like it wants to shut off after 2min it seams to be ok?

I took it in to two dealers it seens that they can't find the problem or don't want to waist there time because warranty does not pay much.

If any buddy have a idea's on this type of matter
 
  #4  
Old 07-17-2009, 03:28 PM
Junior Member
Join Date: Jul 2009
Location: France
Posts: 20
Default HELP Suzuki C90 Running Rough On Cold Start Up

Matchless theme, it is interesting to me
__
Данное сообщение автоматически сгенерировано и отправлено (с обходом всех антиспам защит) программой XRumer 5.09 Palladium. ЗДЕСЬ МОГЛА БЫ БЫТЬ ВАША РЕКЛАМА
Сообщение выше, отправленное ботом с ником CocoChanels сгенерировано АВТОМАТИЧЕСКИ в соответствии с темой и содержимым топика, с помощью новой интеллектуальной системы, встроенной в XRumer 5.09 Palladium. Сам пользователь CocoChanels также зарегистрирован и активирован автоматически, без участия человека.
 
  #5  
Old 07-23-2009, 09:14 AM
Junior Member
Join Date: Jul 2009
Posts: 3
Default

I've seen the same issue only mine will actually stall out if I to not rev the throttle. My wife rides an '04 Volusia and I just let my C90 idle while she has hers warming up with the choke on.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ollie2008
General Motorcycle Tech
2
03-14-2011 01:42 AM
krmendez8
Boulevard M95, Boulevard M50
1
12-31-2010 11:44 PM
cards385
Boulevard M95, Boulevard M50
0
10-06-2009 09:11 PM
820leo
General Motorcycle Tech
1
07-18-2009 08:46 AM
bertie1704
General Auto Tech
1
09-01-2008 07:21 PM


Thread Tools
Search this Thread
Quick Reply: ( HELP ) Suzuki C90 Running Rough On Cold Start Up


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.