Throttle problem

  #1  
Old 06-25-2018, 09:29 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 2
Default Throttle problem

Recently ran out of gas and washed bike for the 1st time on the same day. Since then bike has lag and inconsistency in the throttle (especially in low gears/lower speeds), sometimes cuts out completely in 1st gear, approaching a stop. Not sure if i got sediment from the very bottom of the tank into injectors or elsewhere or got some electrical components wet during the wash. I've only had this bike a week and a half. It's an '05, but well taken care of by prior owner (18,000 miles). It ran flawlessly for me until that day. I've put gas treatment and injector cleaner in a fresh tank of gas (premium) 2 days ago and took it on a 8-10 mile ride. Also blew air filter out and did a quick inspection on the throttle body. No real improvement. Any other suggestions? I want to take a look at the fuel filter, but have not gotten a chance yet.
 
  #2  
Old 06-25-2018, 09:31 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 2
Default Throttle problem

Also, I changed the spark plugs, still no noticeable difference.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MDM50
Boulevard M95, Boulevard M50
2
12-04-2013 02:20 AM
COMINCH
General Motorcycle Tech
5
06-17-2011 04:24 AM
zachariah383
General Motorcycle Tech
2
05-09-2008 06:09 PM
ross007
Boulevard M95, Boulevard M50
3
01-01-2007 01:43 AM
97gixxer600
General Motorcycle Tech
7
11-11-2005 07:16 PM


Thread Tools
Search this Thread
Quick Reply: Throttle problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.