2007 Suzuki S50 starter motor problem and circuit breaker

  #1  
Old 10-16-2014, 11:29 AM
Junior Member
Thread Starter
Join Date: Oct 2014
Posts: 1
Default 2007 Suzuki S50 starter motor problem and circuit breaker

I have problem with starter motor, no longer cranks the engine but
makes a buzzing sound at starter relay. The relay is good, I took it out and checked it on bench, it picks and holds(no load) but when
starter lead wire is connected to the relay upon start the relay buzzes and the starter motor not cranking the engine.
Is there a way to check the starter motor without actually remove it from engine?
The problem happened right after I added fluide to the drained clutch cylinders, the engine goes in nutral OK, seem unrelated to me.
Also the wiring diagram shows a circuit breaker in path, I could not find a circuit breaker in vicinity of fuse box and the starter motor relay, anyone knows if S50 indeed has a circuit breaker and itīs location?
 
  #2  
Old 08-09-2017, 01:31 PM
Junior Member
Join Date: Aug 2017
Posts: 2
Default

I actually am dealing with this same exact problem right now.

I did find that the fuse box is on the left hand side of the bike underneath the cover there.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Lesismore
Boulevard S83, Boulevard S50, Boulevard S40
0
06-27-2011 11:04 AM
mk2gti
General Motorcycle Tech
0
02-05-2008 01:13 AM
yellow87cam
GS500F, GSX-R1000, GSX-R750, GSX-R600
3
08-30-2007 09:53 PM
djem
Suzuki Sportbikes
1
06-02-2007 03:37 AM
Snafoo
General Motorcycle Tech
0
04-20-2007 12:54 PM


Thread Tools
Search this Thread
Quick Reply: 2007 Suzuki S50 starter motor problem and circuit breaker


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.