Battery, Solenoid, Starter

  #1  
Old 08-22-2017, 01:31 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 2
Default Battery, Solenoid, Starter

Hello everyone. I ride a 2006 Boulevard S50 V800

So recently I was having some electrical trouble. My bike was running just fine one day and then wouldn't do anything the next. I replaced the battery, and then there was a strange noise from the solenoid. I replaced the solenoid, and everything worked pretty much fine for a day or two.

Yesterday while riding, my connections to my battery terminals had come loose and I completely lost power to the bike. Once I had re-connected everything and made sure that they were secure I tried to start the bike back up, but it seemed like my solenoid was stuck ON. My starter motor was just spinning and spinning. I disconnected the + lead from the solenoid, and just bridged it directly and it started up fine, and with that lead off, there was no consistent power... so it stayed off.

I just was wondering if there was something else I need to check before I just chalk this up to a defective solenoid?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ummtasty
GZ250
0
08-03-2017 05:54 PM
perry48
Boulevard C90, Boulevard C50
0
04-09-2012 08:27 PM
lovmyxl7
Suzuki XL-7
0
02-01-2009 12:01 AM
djem
Suzuki Sportbikes
1
06-02-2007 03:37 AM
Snafoo
General Motorcycle Tech
0
04-20-2007 12:54 PM


Thread Tools
Search this Thread
Quick Reply: Battery, Solenoid, Starter


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.