General Motorcycle Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

I need help (electrical)

  #1  
Old 04-13-2006, 02:53 PM
Junior Member
Thread Starter
Join Date: Apr 2006
Posts: 1
Default I need help (electrical)

I have a 2000 hayabusa Y Series. The bike set in storage all winter, so when I installed the new battery, it kept blowing the fuel fuse and the instrument panel kept flashing F1. Yes, I installed the battery correctly. When the fuse blow the temp guage reads Hot and the fuel guage reads empty. I`ve checked the fuel relay and its ok. Where do I go from here?
 
  #2  
Old 07-15-2006, 01:36 AM
Junior Member
Join Date: Jul 2006
Posts: 4
Default RE: I need help (electrical)

sounds like you got a grounded wire some where disconnect one of the two faulted gauges replace the fuse try agian if it blows the fuse again then you have narrowed your search. after you figure out which device is grounding follow the wires from said device to the fuse block looking for a break in the plastic coating and repair. good luck...
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Bill
General Motorcycle Tech
21
12-04-2012 11:52 PM
gsxr 600 rider
GS500F, GSX-R1000, GSX-R750, GSX-R600
5
01-24-2008 11:09 AM
19Kilo
GS500F, GSX-R1000, GSX-R750, GSX-R600
0
05-28-2007 07:23 AM
DaveyXXX
GS500F, GSX-R1000, GSX-R750, GSX-R600
5
06-08-2006 12:02 PM
Adam
Boulevard M95, Boulevard M50
2
03-08-2006 12:55 PM


Thread Tools
Search this Thread
Quick Reply: I need help (electrical)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.