Breaks lights don't work when front brake is turned on? - Suzuki Forum - Suzuki Enthusiast Forums

Go Back  Suzuki Forum - Suzuki Enthusiast Forums > General Suzuki Forums > SF Help & Suggestion Center
Reload this Page >

Breaks lights don't work when front brake is turned on?

SF Help & Suggestion Center Need help with SF? Ask. Have a suggestion to better SF? Tell us here.

Breaks lights don't work when front brake is turned on?

  #1  
Old 05-30-2016, 03:23 AM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 1
Default Breaks lights don't work when front brake is turned on?

I have just got an 07 Suzuki gs500f it's my first bike and I noticed that the brake light doesnt work when I apply the front brake? It works perfectly fine when the rear brake is applied but not the front. Has anyone else had this problem? Any ideas where to start?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
carid
Member Group And Special Buys
0
11-27-2015 09:16 AM
Member Group And Special Buys
4
01-02-2014 05:05 AM
Tenimsila
Suzuki Forenza
1
08-04-2006 06:21 AM
hondarules
GS500F, GSX-R1000, GSX-R750, GSX-R600
1
04-10-2006 05:19 AM


Thread Tools
Search this Thread
Quick Reply: Breaks lights don't work when front brake is turned on?


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.