Breaks lights don't work when front brake is turned on? - Suzuki Forum - Suzuki Enthusiast Forums
 
 


SF Help & Suggestion Center Need help with SF? Ask. Have a suggestion to better SF? Tell us here.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-30-2016, 02:23 AM
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 1
Default Breaks lights don't work when front brake is turned on?

I have just got an 07 Suzuki gs500f it's my first bike and I noticed that the brake light doesnt work when I apply the front brake? It works perfectly fine when the rear brake is applied but not the front. Has anyone else had this problem? Any ideas where to start?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Don't miss: Black Friday Sale at CARiD! carid Member Group And Special Buys 0 11-27-2015 08:16 AM
Don't Post Here If You Aren't A Paying Sponsor!! Member Group And Special Buys 4 01-02-2014 04:05 AM
Two right cylinders don't work? - no low an mid-range torque, please help mastroiani 600, 750 0 07-21-2009 11:14 PM
Lights Lights and more Lights??? Tenimsila Suzuki Forenza 1 08-04-2006 05:21 AM
Front Brake chatter hondarules GS500F, GSX-R1000, GSX-R750, GSX-R600 1 04-10-2006 04:19 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.