Loosing Power

  #1  
Old 10-20-2007, 10:09 PM
Junior Member
Thread Starter
Join Date: Oct 2007
Posts: 1
Default Loosing Power

Ok so for the last fews weeks, very randomly my bike has been loosing power...almost feels like its hitting rev-limiter but sometimes it does it at like 8000 rpm and sometimes at high speeds...at first I thought it was just maybe bad gas or spark plugs etc...but ive replaced the plugs and checked all the connectioins with the coils and the injectors and everything seems to be in place...any ideas?
 
  #2  
Old 11-09-2007, 12:41 PM
Junior Member
Join Date: Nov 2007
Posts: 12
Default RE: Loosing Power

I might need a little more information. This is a shot in the dark but it could be your clutch going out. It will feel like your losing power, sort of. I'm not sure if you have ever had this problem before but if that is the case; when you give your bike gas it will rev up but your bike will take off very slow. If thats not the case then give me some more information and ill will try to find out what it is. I work in a motorcycle dealership so one way or another ill find out.
 
  #3  
Old 06-01-2008, 09:09 PM
Junior Member
Join Date: Jun 2008
Posts: 1
Default RE: Loosing Power

About 2 miles after leaving the house, my Suzuki GS500E began to sound hollow or muffled and the horsepower decreased significantly when the rpms were around 3500 - 4000. The bike would rev, but not as well, the off sound increased and the mph did not go up correspondingly. It was hard to go over 40 mph. In another stretch going home, the bike seemed fine, but it happened again before arriving home. There is an aftermarket air-fuel ratio dial, and changing the ratio didn't help. The bike is injected and the exhaust doesn't have a cat. Someone said it could be restricted exhaust or some type of stuck valve by the exhaust header. I looked down the muffler to see if there was any glass, but it seemed to be simply a pipe within a pipe-type design, and there wasn't any resistance when I put something down the tailpipe to check. It just stopped when it hit a bend. Nothing seemed out of the ordinary before then and no work had recently been done to the bike. I had been riding it for mostly 20 minute jaunts this spring, with an average speed of 40-60 mph. Low rpm & speed ok. Does this sound more like a clutch problem or restricted exhaust problem?
 
  #4  
Old 09-29-2008, 03:17 AM
Member
Join Date: Apr 2008
Location:
Posts: 49
Default RE: Loosing Power

Hi,

When was the last time you checked your valve clearances? How many miles on the bike? Have a look at this site: http://www.gstwin.com


Thank you for your indulgence,

BassCliff
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ljf0021
Boulevard S83, Boulevard S50, Boulevard S40
1
12-08-2007 01:05 AM
GsX_bOy12
New Member Area
5
11-11-2005 05:24 PM
mad dog
General Motorcycle Tech
1
11-10-2005 11:17 PM
speedy
GS500F, GSX-R1000, GSX-R750, GSX-R600
2
10-05-2005 08:34 AM
Flyin Hawaiian
GS500F, GSX-R1000, GSX-R750, GSX-R600
3
07-12-2005 07:34 AM


Thread Tools
Search this Thread
Quick Reply: Loosing Power


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.