2007 S40 Kill Problem

  #1  
Old 11-02-2013, 08:46 PM
Junior Member
Thread Starter
Join Date: Nov 2013
Posts: 1
Default 2007 S40 Kill Problem

Bought this bike 4 months ago. Running fine except for the infamous backfiring on decel.
Today I was riding and everything was fine. Weather in Dallas was cool (60 or so). Rode fine with no problems for an hour - all of a sudden when I'd pull up to a stop the bike would sound like a starve out and kill. I could re-start but it would do the same thing. Ran fine once you had it opened up but the first time you came to a stop same thing. Kept re-starting and trying to run it. Then there was a fairly constant fuel drip from directly the air box onto the ground. Seemed to come from a hose that penetrated out of the bottom of the air filter box approximately 1".
Any idea what could be causing this?
Thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kvon Arya
Boulevard S83, Boulevard S50, Boulevard S40
1
08-09-2017 01:31 PM
RudeBoi
Boulevard S83, Boulevard S50, Boulevard S40
0
05-28-2015 01:05 AM
DrDarkWing
Boulevard S83, Boulevard S50, Boulevard S40
0
08-16-2009 12:13 AM
Michael_Js
GS500F, GSX-R1000, GSX-R750, GSX-R600
0
12-13-2006 01:48 PM
CConst9048
General Motorcycle Tech
1
06-23-2005 11:29 AM


Thread Tools
Search this Thread
Quick Reply: 2007 S40 Kill Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.