Electrical issue

  #1  
Old 07-02-2018, 09:40 PM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 2
Default Electrical issue

Hey all. I have a problem I canít figure out. I went to replace the battery in my 08 boulevard C90T. As I was trying to finagle the new battery into place I accidentally touched the pos and neg to the cooler mounted on the front of the bike. Sparks etc, I figured I shorted out the battery and I bought a new battery and installed it (this time without touching anything). My bike still wonít start. I get nothing, I tested the new battery and it tests fine but when I go to start my bike nothing happens, no lights, no horn, no turning over. Am I missing a relay or fuse ? Anyone have anything like this happen to them before ? Any suggestions or thoughts or ideas ? Thanks, Iím new to the forum but not new to riding.

sab
 
  #2  
Old 09-13-2018, 04:19 AM
Junior Member
Join Date: Sep 2018
Posts: 5
Default

Controlla il fusibile generale, solitamente salta quando ci sono corto circuiti, Ť di circa 30 amp, Ť successo anche a me avevo invertito i poli per la troppa stanchezza ed ero terrorizzato ....morta, ma sostituendo il fusibile Ť resuscitata.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gsxr 600 rider
GS500F, GSX-R1000, GSX-R750, GSX-R600
5
01-24-2008 11:09 AM
ljf0021
Boulevard S83, Boulevard S50, Boulevard S40
1
12-08-2007 01:05 AM
speedo09
General Motorcycle Tech
1
07-15-2006 01:36 AM
DaveyXXX
GS500F, GSX-R1000, GSX-R750, GSX-R600
5
06-08-2006 12:02 PM
Adam
Boulevard M95, Boulevard M50
2
03-08-2006 12:55 PM


Thread Tools
Search this Thread
Quick Reply: Electrical issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.